Welcome!

Welcome to Goorm! Learn programming and develop software anywhere and anytime! A cloud coding service, Goorm helps you bring your creative ideas into reality wherever and whenever you want.

Use Goorm for efficient collaboration with other developers. Goorm ensures fun, effective and agile software development.


Join

There are four ways to join Goorm:

  • Link with your Facebook account
  • Link with your Google account
  • Link with your GitHub account
  • Create an account on Goorm using your e-mail address

If you want to use your Facebook, Google or GitHub account, click the relevant logo icon to proceed with the authentication process. If it is your first visit to Goorm (and want to use your Facebook, Google or GitHub account to join Goorm), you need to allow Goorm to access your Facebook, Google or GitHub account.

회원 가입

A verification link will be sent to the e-mail address you entered when you created your Goorm account. Click the link in the e-mail to verify your e-mail address and go to the Goorm homepage.


Login

로그인

You can use your Facebook account, Google, GitHub or e-mail address and a password to log into Goorm. If you have forgotten your password, click Reset Password to begin the process of resetting your password.


My Goorm

Container

Goorm IDE creates a container running independent Linux OS on a virtual machine.

컨테이너 구성

List of Containers Created shows hardware specifications of a virtual machine and whether or not it is running at the moment. Region indicates the location of the closest data center in which the virtual machine is created.

The following window appears when you click New Container. If you have a free account, you are allowed to create only one container. Upgrade your account to enhance your hardware specifications and increase the number of available containers as well.

Choose a programming language that you wish to use and click Create. A container with an environment suitable for the programming language of your choice will be created.

Once Run is enabled after the container is created, click to start a workspace (IDE).

Layout

The following page should appear once you have started the Goorm IDE.

New project

Here is how to create a project using language-specific templates provided by Goorm.

To create a template project, click the icon in the toolbar at the top and a New Project dialog box will open. You can also go to File > New > New Project, or use the default keyboard shortcut, Alt+Shift+N to open a New Project dialog box.

Project Type indicates the language) that you have chosen when starting Goorm and Project Subtype show available language-specific templates. You can search Project Subtype using the arrow keys and Tab key.

Choose Project Types, and then Project Subtypes (a brief description of each template will be given at the bottom). Click Next and enter a project name and description. You must enter a name for your project. Click Create and wait. A new project will be created. The Project Wizard automatically sets up an environment suitable for your settings. You can build or run a project once it is created.

Build

If you have written source code in languages such as C, C++ and JAVA, you first need to build the code in order to get an executable file.

To build, open a project and click the icon on the toolbar at the top. You can also go to Project > Build, or press the default keyboard shortcut, F5. Once the build starts, a new tab called Build will appear at the bottom of the Goorm IDE. This Build tab is a dedicated terminal which shows the result of running the command, Build. Click Rebuild to remove a binary file (i.e., a build output) and rebuild a project. Click Clear to delete everything resulting from running the command, Build.

빌드

This is a build output of a C/C++ project. A 'Build Complete' message appears after a successful build. The resultant binary file is then stored in the path specified in Setup.

Run

If your project has reached a certain stage, run it and check the result.

To run a project, open it and click the icon on the tool bar at the top. You can also go to Project > Run, or press the default keyboard shortcuts, Shift+F5 to run a project.

General

A new tab called Run will appear at the bottom of the Goorm IDE interface when you run a program in traditional programming languages such as C, C++ and JAVA. This Run tab is a dedicated terminal which shows the result of running the command, Run. Click Rerun to run a program again, or click Initialize to delete everything resulting from running the command, Run. This terminal displays output and reads input that you enter.

일반 프로젝트 실행

Server

A new tab called Server will appear at the bottom of the Goorm IDE interface when you run a project in languages requiring a web server, such as PHP, JSP and Node.js. This Server tab is a dedicated terminal which shows the result of running the command, Server. Click any created link to go to a web page that is the output of source code. Choose between two links. Click Stop Server to stop a server. Once Start Server is enabled again, you can run the server. Click Clear to delete everything resulting from running the command, Server.

서버 프로젝트 실행